Do diskuse momentálně není možné vkládat příspěvky. Plná funkčnost bude obnovena v nejbližších dnech. Děkujeme za pochopení.
Úvod > Diskuse > Technické otázky > ADSL Knoppix

ADSL Knoppix

Petr Borecek (28.3.2004 08:33:12)

Prosim vas nasel by se nekdo kdo by napsal tutorial na pripojeni ADSL s modemem ethernet ip 10.0.0.138 v Knoppixu linux nekolikrat jsem to skosel podle navodu na Root.cz ktery je ale psan na Red Had.

Vraána (29.3.2004 09:46:05)

Typ modemu=? "Vytáčí" spojení modem sám (PPP) nebo se musí aktivovat z PC?

Anonym (29.3.2004 17:02:40)

Dik Petre tak to mam (ifconfig eth0 10.0.0.120 netmask 255.255.0.0)ale to vytaceni nevim .

Petr (30.3.2004 13:19:27)

maska by měla být 255.0.0.0 a ne 255.255.0.0 Jestli Ti to funguje v jiném systému, třeba windows, tak napiš jak to máš nastavené. Používáš VPN připojení nebo ne. Co se stane, když v Knoppixu zadáš ping www.seznam.cz a co se stane při ping 212.80.76.3

Petr Borecek (30.3.2004 18:47:26)

Ve win 98 mam VPN eth0 10.0.0.120 maska 255.255.0.0 a modem pronajaty Alcatel 510 bez routeru a zablokovany na konfiguraci (PPP is not available for this product.)jinak je jako 10.0.0.138 mask 255.0.0.0. DHCP configuration = no DHCP.PPTP Connections =RELAY_PPP1/VCMUX/never/in use 10.0.0.120. IP route table Destination Source Gateway Intf Action 10.0.0.0/8 10.0.0.0/8 10.0.0.138 eth0 255.255.255.255/32 any 10.0.0.138 eth0 10.0.0.138/32 any 10.0.0.138 eth0 127.0.0.1/32 any 127.0.0.1 loop 10.0.0.0/8 any 10.0.0.138 eth0

BDs (30.3.2004 19:42:52)

510 bez routeru? Co je to za nesmysl...

Petr Borecek (30.3.2004 21:51:58)

Mas pravdu je tam routing jeste tomu tak nerozumim no ucim se.Jinak dik panove.

Petr (30.3.2004 19:59:21)

V tom případě bych to udělal tak, že bych překonfiguroval modem a zrušil VPN. Pro konfiguraci se používá webové rozhraní na adrese http://10.0.0.138. V sekci advanced je položka setup, kde se dá nahrát nová konfigurace. Z textu v mezi pomlčkama si udělej soubor adsl.ini (případně můžu poslat mailem) uprav JMENO A HESLO a nahraj ho do modemu. Pak v menu zvol Basic a connection a nastav si svoje jméno a heslo. -------------------------------- [ env.ini ] set var="CONF_REGION" value="Czech Republic" set var="CONF_PROVIDER" value="Czech Telecom" set var="CONF_DESCRIPTION" value="Routed PPPoA configuration VPI=8,VCI=48" set var="CONF_SERVICE" value="PPP over ATM" set var="CONF_DATE" value="21 Nov 2003" set var="CONF_VERSION" value="4.0.0.8" set var="HOST_SETUP" value="auto shortcut" set var="UPGRADE_URL" value="http://www.speedtouch.com/upgrade500.htm" set var="DSL_ADDR" value="8*48" set var="PPPoA_userid" value="JMENO" set var="PPPoA_passwrd" value="HESLO" set var="passwrd" value="" set var="HOST_MAC_ADDR" value="00-0B-DB-03-95-C5" set var="HOST_IP_ADDR" value="" set var="HOST_NET_MASK" value="" set var="HOST_GATEWAY" value="" set var="HOST_DNS" value="" set var="HOST_NAME" value="INET" set var="ST_LAN_IP_ADDR" value="10.0.0.138" set var="ST_LAN_NET_MASK" value="255.0.0.0" [ phone.ini ] add name="pppoa" addr=8*48 type=pppoa [ qos.ini ] add name="default" class=ubr [ oam.ini ] config clp=1 [ bridge.ini ] config age=300 [ pptp.ini ] [ dhcp.ini ] config autodhcp=off scantime=20 spoofing=off trace=off policy verifyfirst=off trustclient=on spoof failtime=4 errorlt=60 dodlt=10 pool add name="LAN_private" pool config name=LAN_private poolstart=10.0.0.1 poolend=10.0.0.254 netmask=8 leasetime=7200 start [ mer.ini ] [ ipoa.ini ] [ ppp.ini ] ifadd intf="pppoa" rtadd intf=pppoa dst=0.0.0.0/0 src=10.0.0.1/1 metric=1 ifconfig intf=pppoa dest=pppoa proto=pppoa accomp=on addrtrans=pat ifconfig intf=pppoa user="jmeno" password=_DEV_A5E2E4CE3E92BE7B status=up [ cip.ini ] [ pfilter.ini ] [ pfirewall.ini ] chain create chain="source" chain create chain="forward" chain create chain="sink" rule create chain=source index=0 dstintfgrp=!wan action=accept rule create chain=source index=1 prot=udp dstport=dns action=accept rule create chain=source index=2 prot=udp dstport=bootps action=accept rule create chain=source index=3 action=drop rule create chain=forward index=0 srcintfgrp=wan dstintfgrp=wan action=drop rule create chain=sink index=0 srcintfgrp=!wan action=accept rule create chain=sink index=1 prot=udp dstport=dns action=accept rule create chain=sink index=2 prot=udp dstport=bootpc action=accept rule create chain=sink index=3 action=drop assign hook=sink chain="sink" assign hook=forward chain="forward" assign hook=source chain="source" [ ip.ini ] config forwarding=on firewalling=on redirects=on sourcerouting=off netbroadcasts=off ttl=64 fraglimit=64 defragmode=nat addrcheck=static mssclamping=on apadd addr=10.0.0.138/8 intf=eth0 addroute=no type=1 ifconfig intf=loop mtu=1500 group=local ifconfig intf=eth0 mtu=1500 group=lan ifconfig intf=pppoa mtu=1500 group=wan rtadd dst=0.0.0.0/0 intf=eth0 metric=70 rtadd dst=224.0.0.0/4 intf=eth0 rtadd dst=10.0.0.0/8 gateway=10.0.0.138 type=1 rtadd dst=169.254.0.0/16 gateway=169.254.196.81 rtadd dst=255.255.255.255/32 intf=eth0 rtadd dst=10.0.0.0/8 src=10.0.0.0/8 gateway=10.0.0.138 type=1 rtadd dst=169.254.0.0/16 src=169.254.0.0/16 gateway=169.254.196.81 rtadd dst=192.168.22.0/24 src=10.0.0.138/32 gateway=10.0.0.1 metric=1 [ autoip.ini ] ifadd intf=eth0 ifconfig intf=eth0 addr=169.254.196.81 poolstart=169.254.1.1 poolend=169.254.254.254 netmask=16 ifattach intf=eth0 [ eth.ini ] ifconfig intf=0 type=auto [ dnsd.ini ] domain domain="lan" add hostname="SpeedTouch" stop troff [ dhcc.ini ] config trace=off [ adslisdn.ini ] config opermode=multimode maxbitspertoneUS=13 [ upnp.ini ] config maxage=1800 [ nat.ini ] bind application=IKE port=ike bind application=ESP port=1 bind application=PPTP port=1723 bind application=GRE port=1 bind application=SIP port=5060 bind application=ILS port=ils bind application=ILS port=ldap bind application=RAUDIO(PNA) port=realaudio bind application=IRC port=irc-u bind application=RTSP port=rtsp bind application=FTP port=ftp bind application=H323 port=h323 defserver addr=10.0.0.1 [ system.ini ] setpassword password=_CYP_YiVQUshKGCWb2 config upnp=enabled mdap=enabled dcache=enabled [ endofarch ] --------------------------------

Petr (30.3.2004 20:07:41)

Ještě než s tím budeš laborovat, tak si ulož aktuální konfiguraci do souboru!!!! Kdyby to přestalo fungovat tak se můžeš vrátit k současnému stavu.

Petr (29.3.2004 10:21:46)

Jestli máš modem nastavený tak, že využívá PPPoA tak si v Knoppixu nastav na síťovou kartu libovolnou adresu z rozsahu 10.x.x.x (třeba 10.0.0.10), masku 255.0.0.0 a bránu 10.0.0.138. Pokud bys nastavil modem tak, aby se choval jako DHCP server, tak bys nemusel nastavovat nic. Jestli používáš ještě připojení přes PPTP tak si překonfiguruj modem a budeš mít po problémech.

Petr Borecek (3.4.2004 12:54:49)

To jsem udelal predelal jsem STHome na STpro a Knopix jede zato Win98 ne a ne pingy na ruzny adresy jdou i na www. neco ve voknech ale stranky ne.

Petr (4.4.2004 14:41:22)

Nevím co znamená předělat STHome na STPro, možná tím myslíš překonfigurování z PPTP na PPPoA. Pokud ale chceš poradit, tak bys měl napsat co jsi změnil ve Win. Jestli nic, tak to samo chodit nezačne. Jak máš nastavené TCP/IP na kartě k modemu? Buď máš povolené DHCP a vše Ti poskytne modem, nebo to máš ručně a pak musí být modem brána a musíš si nastavit DNS servery. Jestli Ti nejde jen IE, tak zkontroluj jestli nemáš nastavený Proxy server.

Petr Borecek (4.4.2004 17:37:30)

Uz je to dobry Speed Touch Home je bloklej na nastaveni CIP PPP a par dalsich polozek tak jsem udelal upravu na Speed Touch Pro a jede to supr jako router primo modem ten problem byl ve Win preinstaloval jsem znovu sitovku a TCP a jede to.Kdyz nastavim Modem jako router s pripojenim pres PPP DHCP server Knoppix si vse nastavi sam a frci to . Jen je zajimavy ze kdyz mam modem pres to PPP tak ve Win jsem v DC++ fukcni jen jako passiv a kdyz dam modem pres PTPP +VPN tak uz zas jde i Activ ale to uz neresim jede to dobre.

Anonym (30.3.2004 14:19:39)

este route add default gw 10.0.0.138 pokud nejedes pres PPTP