Do diskuse momentálně není možné vkládat příspěvky. Plná funkčnost bude obnovena v nejbližších dnech. Děkujeme za pochopení.
Úvod > Diskuse > Technické otázky > NATování v SP510i

NATování v SP510i

happymater23 (14.6.2006 19:19:54)

Zdravim, mám SP 510i a v síti server, kde je FTP. Pronatoval jsem si port 21 na ten server (ve R 4.3 je to už automatická předvolba). Všechno fungovalo, dalo se na něj z venčí připojit, ale jako mávnutím kouzelného proutku to už nejde, přitom sem tam vůbec nelezl, zkoušel sem reset a i reinstal FW, nic nepomohlo, ten modem totiž vůbec port 21 nepronatuje a nechá si ho sám pro sebe a otevře jakýsi "vlastní FTP server", kde se přihlásím pod heslem do modemu a normálně se mi načte prázdná FTP složka, kam se nedá nic nahrát. Na ten pravý FTP server se to vůbec nedostane - to vím, protože po nějakém incoming spojení tam není ani vydu ani slechu a to se loguje úplně všechno. thx

Anonym (14.6.2006 19:58:09)

4.3 je desna sracka

happymater23 (14.6.2006 21:58:42)

a ty taky...

Xs (14.6.2006 20:25:08)

Dalo se připojit a již nedá ? Mávnutím kouzelného proutku ? Tady mi něco nesedí . Není důvod aby se takhle router choval i po resetui do defautu. Určitě nastavuješ router absolutně stejným způsobem ?

happymater23 (14.6.2006 22:12:35)

S routerem sem nedělal nic, to vim určitě. Nastavuje se to stejně. Je to až ultra noobské, stačí dát v nastavení routeru "Assign a game or application to a local network device" potom vybrat "FTP Server" a je to. Ješte jsem kontroloval nastavení toho profilu a je správně TCP 21. Tam se nedá nic po****. Stejným způsobem sem si nastavil Warcrafta III abych mohl být host na battle.netu a to jede krásně. Napadá mě jediný zlomový okamžik. Je to kompl s Linuxem a ten ftp daemon se jmenuje proftpd. Jako uživatelské účty pro FTP se používají systémové účty linuxu. Dokud jsem tam měl účet "test" s heslem "test" a s validní shellkou (to znamená že se za něj dalo i přihlašovat do systému) tak to šlo v pohodě. Potom jsem si tam dal už účet "nahotovo" s jiným username a heslem a bez validní shellky a odsud se to po*****. Přitom jsem ale zkoušel tam přidat i účet s validní shellkou a ten taky nejel. Ale jsem si témeř jistý, že pokud by to byla chyba systému, tak se to zaloguje jako neúspěšný pokus. Navíc pokud by byla chyba až na tom kompu, tak by mi to napsalo chybu že je server nenalezen a nenačetlo by se jakési stupidní FTP modemu. Prakticky se ukáže to samé byť je ten komp zapnutý i vypnutý, takže na něj si fakt myslím že nic neprojde. Tohle potvrzuje i to, že z LAN se na ten server dostanu v poho. takže fakt nevim

Legi (15.6.2006 08:40:19)

jen par dotazu pro upresneni - zkousis to z internetu? z jake site? nejsi taky za nat-em? to bys musel mit na ftp nastavenu podporu passiv rezimu a zaroven nastavit rozsah portu i na routeru. jedine, co mne mate, je, ze se to prihlasi na ftp v modemu. tohle jsem jeste nevidel.

happymaster23 (15.6.2006 12:34:18)

ano zkouším to s notebooku kde je GPRS... Ale teďka mám pocit, že to zase zašlo fungovat. Kdyyž to zkusim z exploreru, tak tam se to zeptá na heslo a potom píše že navazuje datové spojení ale nakonec napíše že tam je chyba a že je to timeout. Když to zkusim třeba z filezilly, tak se připojí docela OK. Tohle asi má něco společného s pasiv a ktiv modem, ne? Můžeš mi tohle plz nějak osvětlit?? thx